PackageKit error File \”/usr/share/PackageKit/helpers/yum/yumBackend.py\”, line 1215, in _get_depends_not_installed – Resolved

In packagekit, if you getting the error below:

Traceback (most recent call last):
File \”/usr/share/PackageKit/helpers/yum/yumBackend.py\”, line 1215, in _get_depends_not_installed
rc, msgs =  self.yumbase.buildTransaction()
File \”/usr/lib/python2.6/site-packages/yum/__init__.py\”, line 719, in buildTransaction
self.plugins.run(\’postresolve\’, rescode=rescode, restring=restring)
File \”/usr/lib/python2.6/site-packages/yum/plugins.py\”, line 179, in run
func(conduitcls(self, self.base, conf, **kwargs))
File \”/usr/lib/yum-plugins/remove-with-leaves.py\”, line 71, in postresolve_hook
if opts.remove_leaves or remove_always:
AttributeError: \’NoneType\’ object has no attribute \’remove_leaves\’

then you can resolve it. The solution to the problem is there in the traceback, luckily this time.

So, the problem is with the remove_leaves plugin. Simply remove the plugin and see packagekit working again.

sudo yum remove yum-plugin-remove-with-leaves

🙂